1701天 博客通用头像 Edwiin

本人熟练掌握linux,windows的开关机,擅长nfs,samba,ftp,dhcp,bind,apache,mail等各项服务的安装与卸载,精通shell,mysql,iptables,selinux等单词的拼写,了解虚拟化,存储,集群等相关汉字的书写。

Ex_DirectUI自绘电影解析播放器源码

发布于 3年前 / 2.0k 次围观 / 0 条评论 / 易语言相关 / Edwiin
本文最后更新于2017-6-3,已超过 1 个月没有更新,如果文章内容或图片资源失效,请【留言反馈】,我会及时处理,谢谢!

易语言Ex_DirectUI电影播放器,影视解析,支持优酷、土豆、乐视、爱奇艺等多个解析,可直接做播放器,已经属于一套成品了,我看过很多人发的,感觉这款自绘的播放器算是很完美的啦。
.版本 2
.子程序 PaintObj
.参数 hObj, 整数型
.局部变量 exp, Exs_PaintStruct
Ex_BeginPaint (hObj, exp)
图形_平滑模式 (exp.mGraphics, #平滑模式_最佳能)
pImg = hImg
Blur.radius = 20
Blur.expandEdge = 假
GdipSetEffectParameters_Blur (M_Blur, Blur, 8)
GdipBitmapApplyEffect (pImg, M_Blur, exp.oRcf, 假, 0, 1)
图形_绘图缩放 (exp.mGraphics, pImg, exp.oRcf)
图像_销毁 (pImg)
Ex_EndPaint (hObj, exp)
.版本 2
.子程序 _绘制背景_按钮, 整数型, 公开, 15.默认返回0,若修改则返回非0
.参数 绘画数据, Exs_PaintStruct
.参数 状态信息, 整数型
图形_平滑模式 (绘画数据.mGraphics, #平滑模式_抗锯齿)
.如果真 (状态信息 = #状态_正常)
图形_填充_圆角矩形 (绘画数据.mGraphics, MakeRCF (绘画数据.oRcf.top + 2, 绘画数据.oRcf.left + 2, 绘画数据.oRcf.Width - 4, 绘画数据.oRcf.Height - 4), 高度 () - 5, 默认颜色)
' 文本颜色 (默认颜色)
.如果真结束
.如果真 (状态信息 = #状态_点燃)
图形_填充_圆角矩形 (绘画数据.mGraphics, MakeRCF (绘画数据.oRcf.top + 2, 绘画数据.oRcf.left + 2, 绘画数据.oRcf.Width - 4, 绘画数据.oRcf.Height - 4), 高度 () - 5, 热点颜色)
' 文本颜色 (热点颜色)
.如果真结束
.如果真 (状态信息 = #状态_按下)
图形_填充_圆角矩形 (绘画数据.mGraphics, MakeRCF (绘画数据.oRcf.top + 2, 绘画数据.oRcf.left + 2, 绘画数据.oRcf.Width - 4, 绘画数据.oRcf.Height - 4), 高度 () - 5, 选中颜色)
' 文本颜色 (选中颜色)
.如果真结束
' 图形_描边_圆角矩形 (绘画数据.mGraphics, 绘画数据.oRcf, 4, RGB2ARGB (全局_配色), #虚线类型_实线, 1)
返回 (-1)


全站顶部广告位

  • 支付宝赞助图片
  • 微信赞助图片
  • QQ赞助图片
头像
描述: 还好有你,再见如初。

Press Space to start